FileMaker has clarified the incompatibility between FileMaker v.9.0 and Leopard. Specifically, Instant Web Publishing does not work and the language version you use must match the region that is set in your System Preferences. FileMaker Server does not install on Leopard at all.

You can get more information here:

There are three things to note from this announcement. 1) If you use FileMaker Pro or FileMaker Pro Advanced, but do not use Instant Web Publishing (if you don’t know what that is, you don’t use it), FileMaker Pro is safe to use with Leopard. 2) They will be releasing a patch around November 19. 3) They will never update older versions so, if you intend to move to Leopard at some point, it’s time to upgrade FileMaker Pro to v.9.0.

[Update: FileMaker Pro v.9.0v3 has since been released and addresses all issues with Leopard while FileMaker Server remains incompatible. See the details here.]

[Written by Kem Tekinay]